Register | username: pw: 
Attackpoint - performance and training tools for orienteering athletes

Discussion: Purple Pen has stopped working

in: Orienteering; General

Oct 7, 2016 8:45 PM # 
I have been using purple pen just fine but a couple days ago it stopped working. I get the message "Purple Pen has stopped working---A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available"

I am using Windows 10

I have uninstalled the program and reinstalled (several times actually). I have deleted the one new other program that I installed recently, and I restored my computer to an earlier time. None of these seem to work.

I am pretty sure it is my computer because it still works on my laptop.

Any suggestions?
Oct 7, 2016 9:29 PM # 
Is that the way Win10 deals with software problems, just locking you out?

(Sounds like another reason to avoid upgrading...)
Oct 7, 2016 11:52 PM # 
Pink Socks:
Do you have any large template files in your OCAD file? I've had Purple Pen crash before if I start course designing with an OCAD file that has some pretty big files; usually I remove them before designing, but sometimes I forget.

I upgraded to Windows 10 without any issues.
Oct 8, 2016 12:16 AM # 
Most PurplePen problems are dotNET problems. You may need to run the Microsoft .NET framework repair tool. Also be sure that Windows has all the current updates.
Oct 8, 2016 12:21 AM # 
Maybe it just didn't agree with some of your control locations. Have you used 'boulder field' or 'shallow gully'? I'd be upset too.
Oct 8, 2016 12:38 AM # 
I tried the .net framework repair tool but that didn't help. Thanks for the suggestion though.

It's not a background map issue either because it won't even launch when I do a new download.
Oct 8, 2016 12:39 AM # 
FWIW, I have Windows 10 and I haven't had any problems with Purple Pen. So I doubt that it's a fundamental Windows 10 / PP incompatibility -- rather something more obscure.
Oct 8, 2016 3:10 AM # 
Our club laptop on Windows 10 had a Purple Pen failure to launch issue that seems similar. I haven' t gotten the laptop back to troubleshoot fully yet.

But we did work out a temporary solution to get it to load and be usable in the meanwhile. Login to windows as a different user and the settings files seemed to be different per user so there was no error when opening Purple Pen. I can't recall the exact error message at the moment, but this is something to try to see if it is workable in the short term until you can find the proper fix.

Purple Pen website had some steps to try on the FAQ page if you didn't check there already.
Oct 8, 2016 9:34 AM # 
Terje Mathisen:
@Delyn: This sounds like an uninstall of PP doesn't remove all settings from the Registry, this would explain why a new user would work. I would uninstall once more, then open Regedit and search for all mentions of 'purple' and delete everything that looks like it is related. (Please do a full Registry backup first!)
Oct 8, 2016 11:20 AM # 
@carlch, the background map issue refers to a property of the OCAD file, so you would have to open the OCAD file in OCAD, close any background template that is open, save the file again, and try opening the newly-saved OCAD file in purple pen. Doing a new download wouldn't change the presence of a background template in the OCAD file.
Oct 9, 2016 2:55 AM # 
I followed the PP website procedure and the file checker did find a few issues. I restored the computer to a time before the date on the bad files and ran file checker again. No file checker issues now but PP still won't start. The only difference is that now all I get is an hour glass for a few seconds and than nothing; not even a message from windows.

I did not try the registry search, but I did look at the OCAD files and there were no open background maps. I can't see how that would be a problem in my case though because PP won't even start enough to load any sort of background map.
Oct 9, 2016 10:13 PM # 
I have the same problem with our club computer. Solved it temporarily by opening as a different user. Let me know if you get a fix.
Oct 9, 2016 10:32 PM # 
There is some configuration data in %APPDATA%\Local\Golde_Software
(type that string as it is into the location bar in windows explorer)

You can try deleting that folder or the most recent folder in there.
Oct 10, 2016 7:51 PM # 
Quite a few problems with software here after the Windows 10 anniversary upgrade. Condes and OCAD in particular. Condes opens but menus are inoperative. Grrr.
Oct 10, 2016 8:32 PM # 
What happens in OCAD, Log?
Oct 10, 2016 11:21 PM # 
The main menus at top left refuse to drop down. The buttons below work, but then the dialogue windows are empty and transparent. Also for google earth. This morning I ran a test and OCAD and Condes worked fine. Went into Google Earth and no menus there. Went back to Condes and I have again lost menus. But OCAD is working. Weird. And frustrating.
Oct 10, 2016 11:42 PM # 
Sounds more like a windows display issue than OCAD/GE itself - might be worth reinstalling your graphics card drivers?

My exciting Windows Anniversary experience included Windows unbinding all services from my network card - so the card still existed and was working, but useful things like the Windows networking client and IP traffic wouldn't use it. Handy!
Oct 11, 2016 3:23 AM # 
I can't import a start list into OE Score. It doesn't seem to like the xml file even though the option for import exists and it won't tell me what's wrong with it, just that no records were imported.
Oct 11, 2016 6:06 AM # 
Maybe we can all put windows anniversary into our diaries as a day lost on an annual basis?
Oct 11, 2016 6:06 AM # 

Please follow the full set of steps at:

If doing all of those things, in that order, does not fix your problem, please email me directly at, and I we can try to investigate further.

Peter Golde
Developer, Purple Pen
Oct 11, 2016 6:08 AM # 
For future reference, please use the Purple Pen mailing list for reporting problems or commenting on Purple Pen. I do not generally log into AttackPoint, so reporting problems here will typically not reach me.


Peter Golde
Developer, Purple Pen
Oct 13, 2016 3:03 AM # 
Juffy. It wasn't graphics drivers. I wasn't so silly as to fiddle with that before the Windows Anniversary plus one extra day OS upgrade. Worked fine after that. I think the lesson is to put two days aside around Windows anniversary and just assume all sorts of temporary frustrations will appear and disappear. Go bushwalking outside mobile range.
Oct 25, 2016 2:18 PM # 
Closing the loop on my initial post.

Peter Golde was very helpful but it finally took a computer reset using a system image from 3 months past to resolve the issue and get Purple Pen working again.

I have since updated so everything is current again and PP still works so it's all good.

Please login to add a message.