Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Having trouble connecting to AP with Garmin 910xt

in: Orienteering; Gear & Toys

Dec 26, 2016 2:33 AM # 
I just purchased a Garmin 910xt, and tried it out on a short walk. I was able to get it communicating to my computer, apparently OK, using Garmin Express. When I tried to load my track into AttackPoint, I got a message saying "Sorry, this device is not supported." Is this really the case? If so, I'm going to be quite disappointed with my choice of GPS ... (I tried multiple times and received the same message each time.)

I tried shutting down and restarting the computer after getting the 910xt into communication with the computer, but that didn't help.

Any suggestions? Thanks.
Dec 26, 2016 3:18 AM # 
The 910 is supported, I use one. But you won't be able to use the old Garmin communicator plugin with Garmin Express for any device. You need to chose "upload files" and pick the files directly from the Express sync folder.

on Windows it is something like:
C:\ProgramData\Garmin\GarminConnect\[device id]\FIT_TYPE_4

The "device" your error message refers to is usually some other USB drive, SD card, or something you have connected to your PC.
Dec 26, 2016 7:47 AM # 
Ken, I need some advice also as I am having trouble getting AP to accept my Garmin 910 trace. Used to work perfectly but now gives a message " Garmin plugin was not detected" and says please download it from here and refers to Garmin plugin for Mac. But I downloaded the plug and installed it (hopefully) but is came back with the same message. Not sure what has changed over the past few weeks for this to occur?
Dec 26, 2016 1:11 PM # 
Thanks for the response, Ken. I tried to upload, and I found the file path that you described, but when I finally got to the FIT_TYPE_4 folder, there was just one file in it, which had a multidigit file name and no suffix (creation date was when I connected the 910 to the computer), and was only 1 KB in size. It didn't look promising but I selected it anyway, but as I kind of expected, that wasn't a file at AP was looking for.

Do you know if there is anything I need to do in Garmin Express or Garmin Connect to automatically get the gpx file to be in the FIT_TYPE_4 folder?

I WAS able to manually save the gpx file on my computer and then upload to AP.
Dec 26, 2016 1:23 PM # 
For some reason some versions of Express create those files without extension. But they are .fit files, if you rename them, AP will accept them. FIT files are much smaller than the corresponding GPX, and actually contain more data.
Dec 26, 2016 1:31 PM # 
BB, the newest versions of Chrome have dropped support for the Garmin plugin. Or you may need to reauthorize the plugin if on Firefox. Nothing has changed on the AP side in the pst few weeks. What browser are you using, and which of Express / Ant Agent?
Dec 26, 2016 5:06 PM # 
Thanks again for the help, Ken. I think I'm getting closer. I did a run today, selected "Upload" and navigated to the right folder, where I added the ".fit" suffix. When I selected the file to upload, I received the following message: "Server error converting FIT data. Please try again later." I've tried "later" and still got that message. Is there a plug-in that I need to install, somewhere?
Dec 27, 2016 12:46 AM # 
I use Safari and a Garmin Ant+ which came with the 910XT.
Dec 27, 2016 1:28 AM # 
RLShadow, no plugin is required. You might also have FIT files in
C:\ProgramData\Garmin\GarminConnect\[device id]\FIT_TYPE_4

If not, you can send me the file you have that is giving problems.

BB, it looks like Safari is also dropping support for legacy plugins, so the problem likely begain with a Safari update. You can pick your data files directly, without the plugin. The Ant Agent data location on Mac is
~User/Library/Application Support/Garmin/Devices/Unit ID folder/History

Garmin used to have a page documenting these locations but they have removed it.

You can also try AP's GC web sync, which will just pull your data from the Garmin Connect website.
Dec 27, 2016 3:49 AM # 
I try to avoid browser updates because they tend to put my computer into a worse position than before the update.
Dec 27, 2016 5:54 PM # 
GC Web Connect rules! Mind defaulting to the username field for the AP page, @ken? That would save me about 5 seconds here and there. :)
Dec 27, 2016 6:39 PM # 
Thanks Ken, that file path "C:\ProgramData\Garmin\GarminConnect\[device id]\FIT_TYPE_4" did give me the .fit file which uploaded fine!
Dec 27, 2016 6:42 PM # 
For me, it does default to the AP username, though that may be a Windows thing or a Firefox thing, rather than an AP thing. But since Garmin has arbitrary password rules that won't let me use the same password that I use for AP, I still have to type stuff, because it fills in the same password for the default (and then I have to click the box to say no, don't update this login).
Dec 27, 2016 8:23 PM # 
Ken >> I have noticed the same thing as BB. The communicator plugin on mac+safari stopped working. AP says no plugin detected, but garmin site says it works. For garmin site I need to mark the plugin as trusted but this option never appears for AP?
Dec 29, 2016 7:20 PM # 
Had issues with my 310xt after Garmin Tech Support had me 'upgrade' from Ant Agent to Garmine Express. Ant Agent was no longer talking to Garmin Connect, if I remember correctly.

After transferring workouts to Garmin Connect, Garmin Express removes the files from: C:\ProgramData\Garmin\CoreService\Devices\[device number]\Sync\FIT_TYPE_4

The Garmin\GarminConnect location is the folder that I've been using to upload to AP. Incidentally, Garmin Tech Support told me that Garmin Express doesn't save the fit files at all, so I was happy to find them here.

I've used the AP GC web sync, but I can never remember my GC password, so I just use the file uploader.
Dec 30, 2016 1:38 AM # 
Chrome password sync FTW for GC Web Connect. Or copy/paste from a password manager.
Dec 30, 2016 7:46 AM # 
I have LastPass which works fine if I'm logged in to that.... Just use upload out of habit.
Dec 30, 2016 7:57 AM # 
For mac+safari users I managed to get gc web sync to work after I recalled my garmin connect username and password. But it is more of a hassle than the previous approach.

This discussion thread is closed.