Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Purple Pen error with Microsoft Print-to-PDF?

in: Orienteering; General

Apr 11, 2017 9:34 PM # 
Pink Socks:
Hey all,

I'm using Purple Pen and I'm trying to create PDF's for control descriptions, using Windows 10's native Print-to-PDF as a printer. I'm running into an error. Specifically, it creates a 0 kb PDF file that won't open. I get the same thing when trying to create a PDF for punch cards. I get the same thing when trying to use Print-to-PDF for the map & course. (However, the Purple Pen "Create PDF" functionality works normally.)

I can use Print-to-PDF successfully from every other program I've tried.

I can print everything from Purple Pen on paper.

But when I try to use Print-to-PDF with Purple Pen, it doesn't work.

I've tried the usual:
reinstalling Purple Pen and Print-to-PDF

Anyone else have/had this issue?
Apr 11, 2017 9:53 PM # 
You already made a user error with "using Windows 10". Sorry :)
Can you try starting PPen with admin rights or in one of the compatibility modes.

It might be that PPen for some reason can not write to the location of the file that the default print to PDF program is initially creating the file
Apr 11, 2017 9:59 PM # 
Pink Socks:
This worked for me as recently as 7 months ago. Same machine, and it was Win10 then.
Apr 11, 2017 10:01 PM # 
Can't you export PDFs without using the printing function?
Apr 11, 2017 10:01 PM # 
It worked just fine for me for both maps and control descriptions on windows 10 with the microsoft print to pdf using the sample courses, but I am using the 3.0.0 Beta 4 version of purple pen, not sure what you are using.
Apr 11, 2017 10:03 PM # 
If you are running Purple Pen 3.0.0 beta 3 apparently there can be pdf export problems:

Edit: Never mind, looks like these errors are through the pdf export dialogue, not the printing option.
Apr 11, 2017 10:12 PM # 
Pink Socks:
Can't you export PDFs without using the printing function?

Courses, yes. But for description sheets, no.

I'm using Beta 4 also.

I heard back from the developer and he recommended a specific freeware PDF printer. I installed it, and it works, so I guess my problem has a solution.

Looks like something's amiss with my setup. I had the same issue in November, but after some troubleshooting, I somehow solved it... but that didn't work this time.

Thanks all!

This discussion thread is closed.