Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Upload to livelox

in: Mr Wonderful; Mr Wonderful > 2017-06-01

Jun 2, 2017 2:00 PM # 
MIclimber:
So we can salivate further...
Advertisement  
Jun 2, 2017 2:20 PM # 
Mr Wonderful:
Done!
Jun 2, 2017 4:29 PM # 
MIclimber:
It messed up your splits too :(

Here they are. I got you at 1, 8, 13, 14, you got me at the rest. Although overall difference was 3, 4, 5 for me. We offset your 1 for my 7, and I didn't sprint to the finish really. Everything else were negligible differences essentially.

CP SJS Difference MRW
1 03:32 01:09 04:41
2 04:27 00:45 03:42
3 15:03 08:59 06:04
4 18:17 13:51 04:26
5 08:17 03:30 04:47
6 07:37 00:14 07:23
7 04:57 01:16 03:41
8 03:18 00:45 04:03
9 05:15 00:16 04:59
10 08:09 00:25 07:44
11 06:18 00:13 06:05
12 02:35 00:34 02:01
13 04:24 00:02 04:26
14 02:11 00:13 02:24
15 04:25 00:22 04:03
16 08:52 00:35 08:17
F 03:53 01:56 01:57
1:51:30 1:20:43
Jun 2, 2017 4:50 PM # 
Mr Wonderful:
Other than perhaps two marginally better-selected APs (eg, hill to get to #3, green ringed depression to #4), I sure don't have any margin left!

What is up with Livelox legs? That's my preferred way to compare rather than replay. It seemed like it always worked no problem and now less so?
Jun 2, 2017 4:54 PM # 
igor_:
Not sure, I can try to reload it, but so far no luck.
Jun 2, 2017 4:56 PM # 
igor_:
Okay, I did not have the scale set up, maybe Steve could try to reload his, to see that it helped?
Jun 2, 2017 4:57 PM # 
Mr Wonderful:
I hit the lap button at each tape, not sure if that helps or hinders.
Jun 2, 2017 4:59 PM # 
MIclimber:
I'm thinking it's something with the purple pen xml file and the coordinates. Not sure it's worth it to put a bunch of time/effort into figuring this out since it's just a streamer course, but on livelox inside the course section, and the controls it lists out the gps coordinates for each control. You could compare this with what purple pen is exporting to see if that is where the difference is occuring. My only other guess would be some sort of georeferencing issue, but l think this is less likely, as it all appears to be accurate within 10m or less from what I could tell. Short of those two things, it's maybe just plain old livelox error inside their databases?
Jun 2, 2017 4:59 PM # 
igor_:
I do not think it matters, but you may try to reload yours too.
Jun 2, 2017 5:01 PM # 
igor_:
I mean please re-upload your track (delete and add again)?
Jun 2, 2017 5:03 PM # 
MIclimber:
I reloaded, same result. I think it's purple pen issue. Because I notice Jens splits are doing something similar to what mine did originally. Mine did not pick up #5, his is not picking up #6. So I'm wondering if the issue is with one of those 2 controls. And mine is just screwed and won't overwrite, even though I deleted and overwrote, and tried both strava and direct from garmin.
Jun 2, 2017 5:11 PM # 
MIclimber:
I wonder if Jens, deletes and reuploads his, will it do what mine is now doing and missing number 1?
Jun 2, 2017 5:21 PM # 
Mr Wonderful:
Reuploaded, mine falls apart at #5, where it takes my second pass through en route to #10 and not the first, which is like 5-10 m different.
Jun 2, 2017 5:21 PM # 
Mr Wonderful:
I am using the gpx from AP, not the native fit from my watch.
Jun 2, 2017 5:26 PM # 
igor_:
It may be a limitation of Livelox -- it pretty much finds your last visit near the control and thinks that is when you hit it. One can upload real splits and then it won't try to detect it automatically, but otherwise I guess that's it.
Jun 2, 2017 5:27 PM # 
igor_:
So for Steve it falls apart near #1 since he passed by it on the way to #16, and for Jens it does the same near #5.
Jun 2, 2017 5:33 PM # 
MIclimber:
I'm asking livelox for support, not holding my breath, they tend not to respond.

I don't think it's a file problem, since both jens and myself are experiencing the same issue. It has to be either livelox or purple pen that it's not registering. This has happened to me before, never this badly, but re-georeferencing and reuploading the xml file always fixed it.

Or this was a UFO crash site and leftover magnetism and radiation have actually transformed this section of waterloo into our own personal Fringe episode.
Jun 2, 2017 5:36 PM # 
Mr Wonderful:
Ah, Igor's theory explains the earlier instances of it that I saw.
Jun 2, 2017 8:31 PM # 
MIclimber:
I figured it out. It is a georeferencing issue of some kind.

I created a test livelox event to try to replicate the issues. I was able to correct my #1 by moving the control in purple pen slightly north so that it catches my track better. I attempted to do the same thing with #5, but I was not successful, was seeing the same failed splits as Jens at #5. I tried over a dozen times various locations to try to get it to pass thru my tracks. So instead I removed it altogether and bingo, I now have splits all the way thru.

https://www.livelox.com/Viewer/Winnewana-Test/Trai...
Jun 2, 2017 9:12 PM # 
MIclimber:
I just added Jens track to my test event and his also confirms my theory, full splits without #5 included.
Jun 2, 2017 9:41 PM # 
MIclimber:
On a positive note for me, I picked up another net win at #9 :)
Jun 2, 2017 10:16 PM # 
igor_:
Those controls near the water are to get you around private property anyway, so it's okay to ignore them. Thanks!
Jun 3, 2017 12:31 AM # 
MIclimber:
Got a response from livelox so I moved mine back to the main event for now
Jun 3, 2017 1:52 AM # 
KFish:
End time is set to 6/2 at 7am so it wont take my track
Jun 3, 2017 2:12 AM # 
Mr Wonderful:
Bumped to 6/12 for now.
Jun 3, 2017 2:40 AM # 
MIclimber:
You can change start date/time under edit session to fit into the event's date/time range
Jun 3, 2017 9:31 AM # 
Mr Wonderful:
Now should be published since Thursday and stilll open until next sunday
Jun 3, 2017 11:39 PM # 
MIclimber:
Nothing helpful from livelox yet. My suggestion is to move #1 north approximately 15m (this fixed mine and Mr W in the test environment) and delete #5 altogether to get accurate splits. I played around with #5 again today and moving it to various places and giving up on it. No matter where I moved into my tracks anywhere near where #5 was, it would not pick it up until the return trip to #10. I did successfully get it to register near the rock pile much closer to #4, but that wouldn't work for everyone's tracks. I even looked into the GPS coordinates and seeing it they were offset somehow, but unless it's tolerance is to .0001 degree, I don't have an answer. it's just not registering when it should be. Only thing I can think of besides a georeferencing issue, is something weird in that reentrant happened that can't be explained. Hoping livelox gives me better explantions...
Jun 5, 2017 1:12 PM # 
MIclimber:
Well our 60 Krona is paying off! I heard back from Livelox... "we have made some improvements to the split time algorithm"

The splits are good now, check them out!
Jun 5, 2017 1:43 PM # 
KFish:
sweet
Jun 5, 2017 2:20 PM # 
Mr Wonderful:
Wow, nice work, Steve!
Jun 5, 2017 3:09 PM # 
igor_:
Wow, that's impressive. They just needed a little push to implement that!
Jun 5, 2017 3:47 PM # 
MIclimber:
I was truly surprised when I read that this morning!

Please login to add a message.