Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Attackpoint Plugin for SportTracks

in: Orienteering; Gear & Toys

Aug 16, 2009 5:08 AM # 
greg:
Those of you who use SportTracks software may be interested in a plugin I have recently developed. It allows you to export your SportTracks activities to AttackPoint training log. I tried to make the plugin as customizable as possible to make it suitable for different usage scenarios. I am sure I missed some of them. So, your feedback is very welcome.

You can download the plugin from here and use it for free. The same page has links to documentation.

The current release is of beta quality which means that I am the only person who tested and used the plugin. If you find any bugs please submit them and I will try to fix them in a reasonable time.
Advertisement  
Aug 16, 2009 7:03 AM # 
greg:
Thanks for the feedback.
whyjustrun, if you happen to see this exception again can you send me the log file, please. Click Start->Run. Enter "%UserProfile%/Local Settings/Application Data/ZoneFiveSoftware/SportTracks" and hit enter. Windows Explorer will open the folder. The log file should be there. It is called attackpoint-plugin.log.
Thanks!
Aug 16, 2009 7:50 AM # 
c.hill:
It said export complete yet nothing has showed up on my attackpoint profile!?

Can you reverse the programme? As in download your attackpoint trainings to sportstracks?
Aug 16, 2009 3:19 PM # 
greg:
Theoretically, you can export the other way around. I was thinking about this functionality also. The problem is AttackPoint doesn't support programmatic way of retrieving your training log. One would have to scrape HTML and parse it. So, this is mostly question to Ken :)
Regarding your export problem. I know this is obvious but did you try to refresh the page in the browser? Also are you looking at the same time period in your AP log as your allegedly exported training? You may try to export it again if haven't tried yet. Anyway, I will take a look.
Aug 16, 2009 3:25 PM # 
greg:
All, please make sure you are using the latest version of SportTracks which is 2.1.3478. The version can be seen in Settings->System menu. You can download the latest version of SportTracks from here
Aug 16, 2009 4:31 PM # 
c.hill:
I downloaded the newest version but still nothing shows up on AT
Aug 16, 2009 6:20 PM # 
Stryder:
Absolutely awesome! Thanks much.
Aug 16, 2009 8:09 PM # 
ken:
Greg, you should be able to retrieve training log data via Attackpoint's CSV export. see "reports"
Aug 16, 2009 9:54 PM # 
greg:
Ah. I haven't thought about it. I will put import from AP to ST on my feature list for future releases.
Nov 24, 2009 6:05 PM # 
greg:
I have released a new version of the plugin. All problems reported in this thread have been fixed. Some new features have been added. The download link and the full list of fixed bugs and new features can be found here.
I recommend upgrading to the latest version.
Dec 7, 2009 12:13 PM # 
Strand:
Nice!
Dec 8, 2009 4:49 PM # 
bradc:
Greg. You are my hero! I've been looking for this ever since I started using SportTracks. Thanks!
Dec 8, 2009 7:21 PM # 
jonm:
fantastic :)
Dec 8, 2009 9:25 PM # 
rachael:
i agree, its brilliant! really liking the newest version so I can log 0 distance :)
Dec 9, 2009 7:14 PM # 
greg:
Thank you all, guys! I am really glad you found it useful :)
Dec 10, 2009 12:09 AM # 
rwagnon:
Awesome awesome awesome.
Dec 11, 2009 2:36 AM # 
maprunner:
I want my AP intensity to match HR, and I have matched it up in the plugin. I have also said all the SP intensities are equal to "none" on AP. Now, when I try to export, it tells me intensities are not mapped in the plugin. What do I need to do?
Dec 11, 2009 1:23 PM # 
ken:
I think you can ignore SportTracks "intensity" in this case. You probably want to check the plugin settings box labeled "auto-calculate mixed intensity" and maybe uncheck the one that says "warn about unspecified intensity". Have you defined your SportTracks HR zones? "Other Tasks" > "Select View" > Categories > "Heart Rate Zones"
Dec 11, 2009 2:25 PM # 
rachael:
I get the same problem, but if you "clear" then "recalculate" on the attackpoint tab and then go back to the summary tab before exporting it works fine. It seems that it doesn't know it has the intensities unless you recalc them but i have no idea why!!
Dec 11, 2009 6:59 PM # 
greg:
Yes. The code that auto-calculates mixed intensities is triggered when you switch to attackpoint tab. Until then the plugin doesn't know that you want to export mixed intensities and defaults to regular case. Hence, the message about unmapped intensities. So, the workflow should be like this: 1) Switch to attackpoint tab; 2) Check that mixed intensities look reasonable in case they were auto-calculated or manually enter your own values; 3) Switch back to summary tab or any other tab -- this saves whatever is entered in attackpoint tab into your logbook; 4) Export.
I think it should work even without clicking "clear"/"recalc".
Step #3 can be avoided if and when I fix it :)
Dec 13, 2009 11:38 AM # 
Krügerol:
got a similar problem here. when i switch to the attackpoint tab there are no mixed intensities calculated. if i push the recalc button, i get the message that the mapping for the active heart rate zone is not specified, although it is of course.
Dec 13, 2009 6:03 PM # 
rachael:
hi Krügerol, under settings, Attackpoint plugin, check that the HR zones tab has the correct associations.
I renamed my zones a while ago and got the same error message as I hadn't re-entered the associations...
Dec 13, 2009 10:08 PM # 
Krügerol:
thanks rachael, but in the HR zones tab everything is alright.
Dec 15, 2009 6:52 PM # 
Swisscheese:
I just started using this plugin and really like it. As I most often use my heart rate for the training I am happy to be able to use an automatic hr zone feature to log my training.
Before I was copying it manually from Garmin Training Center (which is actually not calculating the hr zones correctly, as the time just between two zones is counted double... in the lower and the higher zone).
But I don't plan to always use my GPS watch for the training. Is it also possible to use the Suunto or Polar watches with SportTracks?
Dec 15, 2009 6:58 PM # 
Swisscheese:
Actually, does Ken's new GPS feature make this plug-in obsolete?
Would it also do an automatic hr-zone filter?
Most probably it would not read the info from a Suunto/Polar watch, right?

Just asking as I am not yet able to try it out on my log. But my winter season has now started and I need to figure out how I plan to log my trainings for the next season.
Dec 15, 2009 7:18 PM # 
Alex M:
On the SportTracks website I can't find any reference to whether my watch (Polar RS300) is compatible with the software, is anyone using SportTracks with the RS300 as I would like to know before I download it. Thanks.
Dec 15, 2009 7:55 PM # 
ken:
The new gps feature will also work via the ST AP plugin (next plugin release), so nothing is obsolete. And there are some nice benefits of doing it this way, for example there are other plugins for ST which support many additional devices and file types (e.g. GPX). The Elevation Correction plugin is a great one to cleanup the notoriously bad GPS elevation data on your tracks.

I don't know exactly which devices are supported, but I do see plugins for Polar/Suunto import. Also, the AP Garmin transfer does do the auto hr-zone thing, so you can do it either way.
Dec 20, 2009 5:11 AM # 
hughmac⁴:
Hey Greg: delicious. Really nice, thanks! I'm looking forward to the next version (per Ken's last post above) with the mapping feature.

One thing, which is probably a user fumble, but I haven't figured it out ... I prefer English units, and when I export ST > AP (both of which have English units as my default prefs) the distance gets converted to k. Can I fix this up without having to manually edit my AP entries?
Dec 20, 2009 9:09 AM # 
Swisscheese:
The new Plug in for ST is really cool. Thanks a lot!
So, I am trying to get familiar with ST but I have troubles with the HR-zones.
1. Does ST show in its activity reports in which HR zones I have been training in for the last period of time?
2. If I didn't wear a HR monitor for my workout, is it possible to add manually my time in the different HR-zones? (OK, on the AP Plugin I can do so, but probably those data won't be valuable for the ST database and it won't come out on the activity report of ST?

Thanks for your help!
Dec 20, 2009 7:11 PM # 
greg:
@hughmac: actually, it's not a user fumble. Unfortunately, it is a bug. I agree the way it works now is very inconvenient. I will fix it for the next release.

@Swisscheese: I am afraid the answer is "no" to both questions. I might be wrong as I am not an expert in ST. Check out ST forum. Maybe it has an answer.
Dec 20, 2009 7:22 PM # 
greg:
@Swisscheese: Check out this thread, this, and this. I am sure there are more threads on ST forum regarding your questions.
Dec 20, 2009 7:37 PM # 
hughmac⁴:
Thanks greg, I'm just happy to know it wasn't a fumble on my part!
Dec 20, 2009 9:29 PM # 
Swisscheese:
Thanks. I'll read myself through them during my post meal food comas at x-mas.
Jan 17, 2010 8:10 PM # 
greg:
The new version of the plugin is available. A bug reported by @hughmac (English units v.s. metric units) has been fixed.

Many thanks to Ken for integrating export of GPS track. It is available for a limited set of users. See the details in this thread.
Jan 17, 2010 8:24 PM # 
Krügerol:
Tried the new one, but still got the same problem as stated before:

when i switch to the attackpoint tab there are no mixed intensities calculated. if i push the recalc button, i get the message that the mapping for the active heart rate zone is not specified, although it is of course.
Jan 17, 2010 10:31 PM # 
hughmac⁴:
Bingo Greg! Thanks! Definitely looking forward to the GPS track integration as well. Maybe Ken will pity me for being a good bug reporter for Greg? :)
Jan 18, 2010 12:22 AM # 
Juffy:
Ooooh, shiny!

GPS import works nicely, I was hoping this could be made to work. Thanks Greg!
Jan 20, 2010 3:11 AM # 
greg:
I have fixed the bug reported by @Krügerol. So, you should download the latest version if you have the same problem.
Jan 20, 2010 10:59 AM # 
Old_Fox:
great plugin. Thanks!

Installed the latest version, but getting some really weird results - look at my log entry 13th (Wed last week) to see what I mean :(
Jan 20, 2010 12:19 PM # 
ken:
Cool track Old_Fox;-) Looks like a problem in my part of the export code. Greg, I will fix.
Jan 21, 2010 10:32 AM # 
naomi:
hmm, i am somehow still too stupid.... this feature should be available to all of us by now, shouldnt it? i downloaded the newest sporttracks plugin and set it to everybody can see the file. but if i upload my training i dont get the globe with the gps link.

help? :x
Jan 21, 2010 3:11 PM # 
ken:
No, track export is not available to everyone yet. still working out a few issues.
Jan 21, 2010 4:07 PM # 
naomi:
oh, ok. thx :) thought it got implemented with the new plugin. so i will continue to wait! :)
Jan 23, 2010 11:48 AM # 
Juffy:
Greg/Ken,

There seems to be a bit of rounding going on with my more recent imports from SportTracks, eg. this one. If you switch to Hybrid and zoom right in the track is jagged, whereas if I import it directly into AP (via the Garmin importy thing) then it's fine. The track displayed in ST itself is also nice and smooth.

ST v2.1.3478
ST plugin v1.2.117 and .121, both affected.

Is this a known issue?
Jan 24, 2010 2:28 AM # 
ken:
I hadn't noticed this before, but I can see why it's happening. oddly, ST is only giving plugins access to 7 digits of precision for lat/long, which is especially bad at your longitude, where 3 of those digits are used left of the decimal point. it seems to keep up to 15 digits internally, so hopefully there is a way to squeeze 2 more digits out. I will experiment.
Jan 24, 2010 3:39 AM # 
Juffy:
Bug status: Confirmed.
Bug resolution: Suggest user move closer to the UK. :)
Jan 31, 2010 1:10 PM # 
ken:
As of yesterday, track export is now enabled for all current donors (i.e. if you've donated the suggested amount in the last year). There is not a new plugin version for this, but everyone should probably update to the current release, 1.2.0125, especially if you have any problems. (Juffy's jagged track issue is fixed in the current release)

The track view is accessible in your log via the icon next to your entries. If you do not want your tracks published, then you can change that using the "GPS track visible to" setting in Settings > Plugins > Attackpoint or for individual activities on the Attackpoint detail view for that activity.
Jan 31, 2010 10:09 PM # 
hughmac⁴:
Perfect ken! No fiddling, no fuss, works like a charm.
Feb 9, 2010 6:59 AM # 
greg:
The latest version now exports session start time (courtesy of Ken). He also fixed a problem with GPS track upload. You should update to the latest version regardless of your AP account type: basic or advanced.
Feb 28, 2010 8:02 PM # 
daveabrams:
when exporting multiple trainings from the activity reports screen all of the trainings are exported under the same start time. is there any way around this apart from exporting each training separately?
Mar 1, 2010 2:12 AM # 
ken:
What's actually going on here is that exported training activities get their session-hour from the earliest adjacent activity, where adjacent currently means less than 60mins from the end of one activity to the start of the next one. Exporting each activity separately is actually not a way around this, the result is intentionally the same either way.

Maybe the 60min gap size could be configurable in future versions, but in the meantime if you still don't want this behavior, another option is to go back to v1.2.x which doesn't export this value at all, or just correct those cases where it doesn't come out exactly as you want (which hopefully is not every time!)

see here for some discussion of session-hour:
http://www.attackpoint.org/discussionthread.jsp/me...
May 17, 2010 2:46 PM # 
rachael:
all of a sudden my previously working sporttracks -> attackpoint exports have stopped working and i get the following error message:

Request failed with status ProtocolError: The remote server returned an error: (417) Expectation failed. See log file for details.

anybody have any suggestions please?!
May 17, 2010 4:29 PM # 
ken:
I haven't seen that error before, and I don't know what could cause it. I just tried to export something and it worked for me, not that it helps you.

It seems like "417" errors can be related to proxy servers. Do you know if your web connection involves anything like that? Anything else changed recently on your system? Otherwise, maybe try again after restarting ST or your computer...email me if the problem persists.

you can find the attackpoint-plugin.log file in your "%UserProfile%\Local Settings\Application Data\ZoneFiveSoftware\SportTracks" folder, though it may not say anything besides what you quoted above.
May 17, 2010 7:22 PM # 
rachael:
thanks for the help ken
I can't find that location on my computer (is it the same for vista?) - I've found a sporttracks folder in program files but there's nothing resembling a log file in it...
I'm on a german hotel internet connection (high speed via a cable), could that be it?
May 17, 2010 8:39 PM # 
ken:
Windows can find that folder for you if you just paste the whole path into a folder location bar or start->run prompt, but don't worry about that too much.

I'd guess that the hotel internet is the problem, especially if you had to click through some login or "I agree" page before you could get to the web in your regular browser the first time. The export plugin wouldn't be able to handle that scenario properly. Unfortunately I can't think of a work-around, you may be out of luck while you're there.
Aug 14, 2010 7:05 AM # 
Heliveikki:
Have you noticed that Sports Tracker (not Sportstracks) has re-opened as of August 12th 2010, and it's better than ever. It would be fantastic if one could have a plugin for importing the training information from there to AP..anyone planning to implement this?
Feb 13, 2011 10:53 PM # 
Peter H:
My sporttracks/AP uploading has also stopped working.

After clicking "export Attackpoint training" I get the message "Unable to authenticate on Attackpoint"

The log file response is
"13/02/2011 22:45 [DataImporterManager] ERROR An exception occurred in call to plugin IExtendDataImporters.BeforeImport().
This BackgroundWorker states that it doesn't support cancellation. Modify WorkerSupportsCancellation to state that it does support cancellation.
at System.ComponentModel.BackgroundWorker.CancelAsync()
at ElevationCorrectionPlugin.Download.DownloadHandler.PreDownloadDemBlocks(IEnumerable`1 logbookEntries)
at ElevationCorrectionPlugin.Import.ExtendImport.BeforeImport(IList items)
at ZoneFiveSoftware.SportTracks.Plugin.DataImporterManager.InvokeBeforeImport(IList items)

"

I have tried getting Sporttracks 3 with the new plugin, but I get the same problem whichever version of sporttracks I use...

Any suggestions?
Feb 13, 2011 11:24 PM # 
ken:
I think that logging out and back in should fix this problem. I didn't see a logout option in the plugin, but try this:

- Go to Settings > Plugins > Attackpoint
- Clear your username (leave your password typed in)
- Click "Retrieve Attackpoint Profile" (you should get an error)
- Now retype your username and password, and "retrieve" again.

it seems like you won't get an error here if you mistype your username or password, so make sure you get them right. this could also be your main problem.
Feb 14, 2011 7:35 PM # 
Peter H:
Perfect! Thank you very much!

This discussion thread is closed.