Register | username: pw: 
Attackpoint - performance and training tools for orienteering athletes

Discussion: Garmin Uploading Problem

in: Orienteering; The Website;

Jan 29, 2011 8:04 PM # 
Canadian:
I'm having an issue properly uploading data from my Garmin (405 - correction: 410) that I've yet to see discussed on AP. The Garmin communicator shows the correct full workout time in the list of workouts but when I upload it Attackpoint doesn't show the full time...You can find a screenshot of the issue here.

Any insight or hints Ken, others?
Advertisement  
Jan 29, 2011 8:43 PM # 
RLShadow:
I have an issue (with a Garmin 205) that sounds somewhat similar, although I'm guessing it isn't exactly the same:

I finished my run (yesterday) at 2.70 miles exactly, which was about three tenths of a mile from home; I then hit "Lap" rather than stopping the GPS, mainly because I wanted to take my pulse. I left it running until I got home, when I stopped it, reset it, and then deleted the second lap (the part where I walked in from 0.3 miles out) because that wasn't part of the run.

When I loaded the workout into Garmin Training Center, it gave the expected distance of 2.70 miles.

But when I loaded it into AP, it gave 2.99 miles, which would be the total distance including the three tenths of a mile walk at the end. But the time was the elapsed time of my first lap only (in other words, the correct time for the actual running portion).

Since I deleted the lap from the GPS before loading it into AP, why does it still pick up the distance of the second lap? And just as puzzling, why does it NOT pick up the time of the second lap, if it picks up the distance?
Jan 29, 2011 9:34 PM # 
ken:
Jeff, I'm not sure what is causing that problem. If you can email me the TCX file I will be able to take a closer look.

RLShadow's problem is a bit easier to explain. The garmins store lap and track info separately, so as you can see by looking at the map in your log, deleting the lap (I didn't even know you could do that) didn't actually delete that part from your track. AP tries to get the total time from adding up your lap times (this is more accurate when you have pauses), but the distance currently comes from your track. I can look into reading the distance from the laps.
Jan 30, 2011 12:25 PM # 
RLShadow:
Thanks for the insight into my issue, Ken. It's very odd -- when I go through the process of deleting the lap from my watch, it definitely appears gone. It no longer shows up on the watch's display (the watch says I only have done one lap, not two), and the distance and time is the correct distance for the running portion of my workout.

But yet the GPS track for the second lap must still actually exist! Because AP obviously finds it; but not the time of the second lap. And when I looked carefully at the GPS tracks in Garmin Training Center, I see that the second lap still show up, in the track, but not in the distance summary.
Jan 30, 2011 8:04 PM # 
gas_turbine:
For me, after uploading 5-8 workouts, I'll intentionally erase the data stored on the garmin. Otherwise, it will refuse to upload.

Not the best solution for me, but the one that works.
Jan 31, 2011 1:06 AM # 
bl:
I've had uploading blues at times, too. Have not erased any trng data yet (maybe 30 total). Have had to close that particular trng session & start again and maybe even again. Have uploaded with the 305 on & off. Haven't studied but think I'm more likely to be successful if it's off. Don't believe I saw any comment in the owner's manual regarding this.
Jan 31, 2011 3:50 AM # 
ken:
Jeff's problem was an AP bug related to intensity-0, now fixed.
Jan 31, 2011 4:03 AM # 
ken:
If you are having problems with the transfer freezing with the 205/305 (this is the garmin plugin crashing) it does seem to help if you delete old sessions once in a while, or when the problem comes back. It is usually enough just to delete really old ones (History > Running > Delete > Keep 1 month).

I think the reason this is a problem is that while old tracks get automatically deleted as needed to make room, the summaries (lap times, etc) are never deleted. eventually you'll get enough to make the communicator plugin barf sometimes or all the time.
Feb 1, 2011 1:32 AM # 
gordhun:
Thank you very much for the wandering this discussion took. What started as a Garmin / AP problem came around to the same problem I'm having with my 405. Pleas to the Garmin help page have gone unanswered. When I get home on Thursday I'll try (History > Running > Delete > Keep 1 month)
Thank you Ken
PS does everyone have as much trouble getting a response from Garmin? I once suggested they add orienteeering to the activities on the drop down bar for the dashboard. Only response was that I should join their discussion group.
Feb 1, 2011 2:30 AM # 
ken:
As far as I know, this particular crash problem only affects the 205/305. Can you say more about what symptoms you have with your 405?
Feb 1, 2011 12:00 PM # 
Tooms:
A separate thing I've noticed (again now I have a newer GPS) is that as time goes on each upload takes longer and longer to parse. So long I get bored waiting, whereas when the GPS was new for the first few weeks it was just a couple of seconds. (I've always deleted the >1 month stuff).
Feb 1, 2011 3:04 PM # 
ken:
Tooms, the 310XT has a different old-session problem that will cause the Garmin communicator to slow down over time. The watch doesn't retain sessions, but the folder on your computer where ANT-agent syncs data to is never cleaned up, so the communicator has to parse more and more data every time, causing the slowdown. here's what to do:

* Find where your data is stored on the PC.
Win7: C:\Users\[your username]\AppData\Roaming\GARMIN\Devices\
XP: C:\Documents and Settings\[your username]\Application Data\GARMIN\Devices\
MAC: ~/Library/Application Support/Garmin/Devices/

AppData, Application Data, and Library are normally hidden folders, so depending on your settings you may not see them. but you can type the name directly.

* Remove old data. Look in the folder [your device id]\Activities\ You probably have a ton of FIT files, named by session date and time. Move older ones somewhere else if you want to keep them, or just delete them. Don't remove files from sessions you still want to upload to Attackpoint.
Feb 1, 2011 7:28 PM # 
gordhun:
Ken,
My 405 was working fine and downloading on demand from July '09 to Jan 8 2011.
Since thern it has been recording training and splits on command and resetting in 3-2-1 as always. However when I go do download to my computer it goes through the motions for a fraction of the time it normally takes to download then starts to act as if its finished the job. However no downloaded information shows up on the computer to be uploaded to the Garmin 'dashboard'.
I was always under the presumption that I had the watch set to delete workouts once they had been downloaded.
Feb 2, 2011 9:03 PM # 
ken:
I sometimes see weird download things like this with my 405, here are a few different things to try (in any order)

- make sure the 405 is close to the USB receiver, like right next to it.
- reboot your computer
- unpair the watch (ANT agent > device settings > remove device), and then try re-pairing.
- soft-reset the 405 (hold both buttons for about 10s until screen goes blank)
- make sure you have the latest version of ANT agent and 405 firmware, though it may be hard to update the 405 if you have connection problems.
Feb 2, 2011 9:08 PM # 
bubo:
Ken,
I had some problems with my 305 when downloading my 6 hour ski-race this past weekend. The clock was running and showing distance and time the whole race (lost satellites a couple of times though) but when I downloaded I only got data from km 25 and the last 45 km of my 70 km race. Total time was correct in the downloaded data but km-splits, pulse and GPS data missing from the first half.
My guees now is that this sounds like a "too-much-stored-in-memory"-type problem (I very seldom clear the memory so that shouldn´t really be a surprise) or is there some other issue concerning file size or max limit of data stored per session?
I started with the AP download but then also tried Garmin TC, SportTracks and GPSBabel with the same result...
Feb 2, 2011 9:11 PM # 
ken:
From your log, it looks like you have the 305 set to 1s recording interval. In this mode it can only hold ~3.5 hours of track points, so unfortunately the rest are gone. they are automatically erased to make room for the most recent data. Smart recording mode will get you more like 10-12 hours of data at 2-5s intervals.

The session summaries are stored separately (and not automatically erased), so that's why it still knows your full time and distance values.
Feb 2, 2011 9:25 PM # 
Cristina:
Regarding the 405 and downoading issues, I've found that I can get fairly consistent downloads if I quite the (Mac) ANT agent and remove the ANT USB device between downloads. I always start the ANT agent first, then plug in the ANT USB device. This usually results in communication between the watch and the computer within ~30 seconds or so. Otherwise it's just a crap-shoot.
Feb 2, 2011 9:40 PM # 
bubo:
OK, thanks Ken!

That would be the the answer then - I always use 1 sec recording interval for my O races and other training, but it sounds like I should use the smart recording for my longer sessions in the future then...
Feb 9, 2011 1:33 PM # 
tRicky:
Thanks for answering one of my questions Ken (although it was Tooms that asked it).

Two days ago my computer downloaded a new version of Training Centre for the ANT Agent and ever since the AP plugin has uploaded my elapsed times for training sessions rather than the actual travel times (e.g. if it has auto pause on or if I stop the GPS during the session it still includes stopped time). Any ideas why it's suddenly doing this because it wasn't doing it before? I also cleared the Garmin's memory that day so not sure which issue has caused the problem.
Feb 9, 2011 5:11 PM # 
ken:
I let my pc's ANT agent auto-update a few days ago, and the problem is happening to me now also, but I hadn't realized it.

A few things have changed about the way stopped time is handled when ANT agent saves TCX files from the 310XT. Garmin seems to have fixed one problem (pauses used to be included in track data) and introduced another (now pauses are included in lap times!).

I have an AP fix that I will push out later today, once I make sure it doesn't break anything else.
Feb 9, 2011 10:44 PM # 
tRicky:
Thanks for that! Always the tireless worker.
Feb 10, 2011 12:14 AM # 
ken:
This should be better now. You can fix an affected session by clicking edit, then re-transferring into it.
Feb 10, 2011 4:39 AM # 
tRicky:
That might work if I hadn't already deleted it from the ANT Agent using your earlier tip ;-)
Feb 10, 2011 4:50 AM # 
Juffy:
Users, eh? Can't live without 'em, can't stop 'em doing stupid things.
Feb 10, 2011 12:47 PM # 
ken:
Actually, if you only deleted the TCX files, you can still re-transfer those sessions.

It's because my AP fix was mainly to change the 310XT transfer mode from TCX to FIT files (which are now supported for the 210). Another side effect is that the old-TCX file problem is now a non-issue, you shouldn't need to do any more cleanup.
Feb 10, 2011 3:01 PM # 
tRicky:
Weird, I seem to recall deleting everything from the Garmin but it's all still there (apparently, shows up when I download to AP). Probably reappeared as TCX or FIT files now.
May 7, 2011 1:24 AM # 
tRicky:
Hi Ken, me again. I've recently "upgraded" to the latest version of Internet Explorer. In doing so, the Garmin plugin disappeared from AP, so I reinstalled it. However, now when I try and upload workouts I get the following error message from IE:

UnsupportedDataTypeException: Your device does not support reading of the type: FitDirectory

AP states: "Found 1 device, reading..." and goes no further.

Have you encountered this problem and/or know how to fix it?
Thanks
May 7, 2011 1:42 AM # 
ken:
I hadn't noticed this before, it happens to me too. I will track down the problem, but it looks like you can work around it by enabling IE9's "compatibility view" (click that broken document icon in the url bar).
May 7, 2011 1:53 AM # 
tRicky:
So simple, thanks Ken. In honour of your assistance, I promise not to use the marquee function in this message.
Sep 28, 2011 9:59 PM # 
mellis:
I've had a few problems with my 305 lately (it worked great from 2008 until recently. Once it lost my previous workouts on the computer but these have magically reappearled (2008 to 2010). All of my workouts since May 2010 have disappeared and it won't download the new workouts that are on my watch. It tells me that "your workouts and courses data was successfully received for your fitness device. There was a problem receiving the activities."
We have two devices connected to the Garmin s/w. The other device also lost its workout back to the same date in 2010. I updated the s/w when I ran into these problems. We're running v. 3.5.3.
Any suggestons for a fairly non-Garmin-literate user? Thanks.
Sep 29, 2011 5:33 AM # 
cedarcreek:
Garmin support came through for me a few days ago. Worth a try: http://www.garmin.com/us/support/contact/ (assuming you're in the US)
May 24, 2012 12:09 PM # 
Wyatt:
FYI - For those of you with blue-screen-of-death (bsod) crash issues with your Garmin Forerunner or Edge 305, Garmin finally fixed their USB driver, earlier this month - Windows - Device-Manager - Garmin-Devices - ... - Update Driver (to 2.3.1.0) should do the trick.

https://forums.garmin.com/showthread.php?t=10735&p... is the thread
May 24, 2012 1:51 PM # 
furlong47:
Oh maybe it will finally work with Windows 7 now. I'll have to try tonight.
May 24, 2012 1:54 PM # 
tRicky:
Now if they'll just fix the ANT Agent.
May 25, 2012 8:40 AM # 
Juffy:
Ooooh, shiny. Thanks Wyatt.
May 31, 2012 3:47 PM # 
loefaas:
I just encountered some very strange problem on my last upload. It appeared a huge amount of sessions that I hadn't done and are not in the watch either (like 3 morning sessions and 3 evening sessions on a day I had rested, and nothing when I check the watch) garmin or attackpoint problem?
May 31, 2012 4:25 PM # 
tRicky:
Blame Garmin - it's easier and probably correct.
May 31, 2012 5:53 PM # 
bshields:
This seems to be a fairly common problem, at least I've had it several times and I know other people have encountered it as well. In my case it generally requires restarting the browser or rebooting. Finding a better internet connection and clearing out the garmin memory frequently to reduce the upload time seem to help as well.

This discussion thread is closed.